My idea is/I suggest you ...

Videos Not Playing

The last two days, videos have not been playing for me. The audio is fine but the visual component is either a black screen or frozen. My Flash Player is enabled and up to date. I use Firefox in Windows 10. The playback from other sites is fine.

8 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    M shared this idea  ·   ·  Admin →

    9 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Anonymous commented  · 

        The screen is black when I try and play a video. I have an updated chrome on a mac. Could you help me with this issue please

      • Anonymous commented  · 

        No videos have been playing for me for over two weeks. I use Google Chrome browser and it updates Flash player automatically.

      • abutt4u2000 commented  · 

        I'm not able to view videos but can hear them

      • Anonymous commented  · 

        mine too, video not playing
        flash player and chrome is updated

      • randpat commented  · 

        Same problem some videos play and others play sound with no audio. Used Firefox and Chrome on my mac.

      • SC commented  · 

        no videos will play for me in Firefox. I haven't tried another browser, but shouldn't have to. Yep, flash player is up to date. This has been an issue for almost a week.

      • edmond commented  · 

        I also use Firefox and I did make sure that the most recent version of Flash-player is installed. Yet, I continue to have trouble playing videos. The first video will play. But when I attempt to play the second video it will not work. I hear the sound, but the picture is frozen. If I log out and come back, again the first video will play, but not the second.

      • M commented  · 

        I double checked. It's enabled. Besides, as I said, your site is the only one with a problem. Other sites play videos fine. So far, I haven't found a video that actually works but here's a link: http://www.xtube.com/video-watch/Asian-top-29333421

      Feedback and Knowledge Base